Get_sub_volume function in C1W3_Assignment

Hi, I am working on the get_sub_volume function and have been consistently getting wrong dimension errors. However, I am very confused about how am I able to resolve it. Is there a chance that a mentor can look over my code and give suggestions on how to modify it?

Can you share the screenshot of the wrong dimension

Thank you!

You need to share this part of the output

Did you use the hint part before the grader cell to do the code??

Sorry, but that is all the output I got plus an error message.
Yes, I have looked at the hints and believe I have used them (at least I used the three functions in my code)

check your num_classes? what you have put code for this.

check this post, same error output, see if it helps understand

Otherwise share your this part of the code in personal DM. Click on my name and then message. Do not post your code here.


I wanted this screenshot only as it gives idea where one might be going wrong

Hello Xia,

the code you sent the only change you need to do is use tf.keras instead of keras as these are updated assignments.

If you still are getting error output, then one needs to look issue in previous grading cells also



Did you get the expected output after the correction??

Hi Deepti,

The problem still persists even as I change keras to tf.keras. Also this is the first grading cell out of all cells so I am supposing no cells before that would be causing the error?

are you getting the same error?

If yes then send the update notebook via DM. Probably the error might be related to other cell. Please click on my name, then message.