Getting an error saying There was a problem grading your submission

Uploading: Output of the same exercise 7 in the VS code with correct expected output.jpg…
Uploading: Error in the jupyter notebook of cousera course.jpg…
please help

Hi @Advait_Ambardekar,

At the start of the notebook there’s:

**Important Note on Submission to the AutoGrader**

Before submitting your assignment to the AutoGrader, please make sure you are not doing the following:

1. You have not added any extra print statement(s) in the assignment.
2. You have not added any extra code cell(s) in the assignment.
3. You have not changed any of the function parameters.
4. You are not using any global variables inside your graded exercises. Unless specifically instructed to do so, please refrain from it and use the local variables instead.
5. You are not changing the assignment code where it is not required, like creating extra variables.

If you do any of the following, you will get something like, Grader Error: Grader feedback not found (or similarly unexpected) error upon submitting your assignment. Before asking for help/debugging the errors in your assignment, check for these first. If this is the case, and you don't remember the changes you have made, you can get a fresh copy of the assignment by following these instructions.

This clearly mentions if you do any of the listed things you will run into Grader Error: Grader feedback not found.

Please make sure you are not doing any of these listed things.


yes i read the instructions and followed them aswell. Can i share you the python file for the check?

My lab id is xcvzcpbutlty

Thanks for sharing this. I’ll check it out in a bit.

Hi @Advait_Ambardekar,

Just so to clarify, the lab ID you shared is of C2 W3 assignment. And you have posted this query in the C2 W2 category. Is the lab ID correct ?

My apologies sir. This is the code foe week 2 otmlfmvdxhuh. Also i’m having same issue with in week 3 and 4 as well.

Hello sir can you help please

Hi @Advait_Ambardekar,

I realised you see two “submit” buttons in your assignment. Have you been click the one on the right ? You have to click the one on the top (I have removed the right side submit button from your notebook).

Once you click the submit button on the top you’ll see 50/80 from your grader. You can then click to see which exercises failed and work on them.

Do the same for your other assignments as well.


I was using the one on the top only sir. My issue was the error I was getting inspite of not using the global variables.
Also in some exercise it says test case passed but shows 0 in the final result.

Also can you give me feedback where i am wrong using the lab code for week 2 “otmlfmvdxhuh”

Hi @Advait_Ambardekar,

I just came to realise, and please, don’t deny it, the work you are submitting is not your own.

You have taken these notebooks from elsewhere and tried to submit them as your own, which is why you are failing the grader. The notebooks you have used are an older version of the assignment. Very old.

All the NLP mentors and myself, we are happy to help all of the learners, as long as the work they are doing is their own and making an effort. What you have done is against the honour code of this community and of Coursera. I suspect you have done similar in your other labs as well.

Please try again, and submit your own work. All the learners and mentors are here to help you along the way (as long as you are making an effort and not finding shortcuts)


Good Evening Sir,
The notebook that you saw was the one to which i was referring genuinely.I had no intention of copying it . I would not deny that, i just had it for reference. I used it after trying for many times and to see what were my mistakes in my notebook. I was unaware of the Learning.AI community untill i contacted the coursera helpline.
So can you help me reset my notebook for the weeks so that i could start fresh.

Hello sir
In week 2 lab i’m unable to access the page it says " 404 : Not Found

You are requesting a page that does not exist!"

Hi @Advait_Ambardekar,

Please refer to this FAQs for instructions for how to get the latest copy of the notebook.


It is because you changed the name of the notebook file. When you press to open the lab, it looks for the default filename. Since you have changed the name, it can’t find it, hence, 404 error. Refer to the FAQs to fix that.

i could not find my error in the given FAQ sir . I tried the reboot option but that also did not help

i.e my juypter file itself is not opening

It is the first one, “Get a clean copy of the assignment”

still having the issue