I cannot complete my graded assignment

I’m having a difficult time completing my graded assignment. Specifically with the Split_data function. The function is complete. When I tried testing the function, I always ended up with this error. Help! I’ve been stuck for weeks.

I have not taken that course and am not a mentor for TF, but you should be able to debug this. So something is wrong with the pathname that you have constructed there. If you are working on the course website in a Jupyter notebook, click “File → Open” and then click “New → Terminal”. That will give you a new window with a linux shell and you can explore the file system tree that comes with your assignment. E.g. try:

cd /tmp
ls -lR cats-v-dogs

That should give you a picture of the file system. Why is the file name you tried to open not there? Either your code for constructing the path is incorrect or perhaps the file system tree with your assignment is incomplete for some reason. Following the “Get a Clean Copy” procedure documented here will refresh any missing files.

Thank you. I will try that.

Hello @Aminu_Musa! First, I would like to say that it’s normal to get stuck at some points, and I know it can be frustrating. However, let’s try to solve this problem together and make progress in finding a solution. The most important step you’ve already taken by sharing your difficulties.

Looking at the image, I noticed that there is a ‘testing’ folder in the path. I’m not sure if you tried some command lines before, which generated a new folder. In the beginning of the cell, the paths are defined for the variables CAT_SOURCE_DIR, DOG_SOURCE_DIR, TRAINING_DIR, and VALIDATION_DIR. I tried to identify what might be different in those lines, but please continue updating your question here.

We’ll work through this together and find a solution. Don’t hesitate to provide more information or ask for further assistance.