Jupyter notebook fails to load up the assignment. Fails with SBOX_FATAL_MEMORY_EXCEEDED

My Jupyter notebook with assignment on “Planar Data Classification with One Hidden Layer” has suddenly stopped loading on browser. The browser waits for some time and then throws error saying not enough memory. It fails w/ error code SBOX_FATAL_MEMORY_EXCEEDED. I am unable to complete my assignment and submit the same. Please help.
I was almost done with my assignment. Towards the end of the assignment, there was a particular code snippet that was supposed to take few minutes because it was compute intensive. That was mentioned in the assignment. The problem started when I started running that segment. After that, everything stopped working. I tried Chrome browser and Microsoft Edge. It fails all across. I tried stopping the kernel, rebooting the server (from “help” on the right side). Nothing succeeded in getting me past this hurdle. Please please please help.

Here’s another recent thread about this error.

Did you add any print statements that make your output very large? That can cause the memory footprint of the notebook get too large. You can try getting a clean copy of the notebook by doing “Help → Lab Help → Get New Version”, if you can click that link. But that only replaces the notebook if it has been renamed, so it may not really help unless you can first get the notebook open and rename it.

Try the things suggested here and on the other thread. If none of that works, we may have to see if the course staff can reset your notebook for you.