Layer Error when running the notebook and no insight into why

For context: This appears to be the re-released version of the course using trax 1.3.9

Please note that I’m reposting this as the first round didn’t get a useable response in coursera and the second round was initially posted in the wrong category here, so also doesn’t look like it’s headed for success. Not trying to spam the channels, simply still looking for help after 4 days.

I’m baffled by this error, as everything until now has been fine, passed all unit tests, etc., and this cell doesn’t seem like a challenging one, as I’ve implemented effectively the same function for the last 3 weeks or so. No idea what’s causing this error; the little documentation I found online about similar errors indicated issues with demo notebooks, which doesn’t seem useful as a troubleshooting guide. Would be thrilled if someone has an idea as to what could cause this in the training_loop function.

Have also checked my masks, as the end of the stack trace is indicating an issue there, but since that issue is in the code base, I’m unclear as how it would be referring to my functions.



Full Stack Trace can be found on the coursera forum where I posted this question the first time.

Can’t tell where the error is from, but I passed this assignment a few days ago, so I assume we use the same version of Trax. I remember there were problems when I didn’t pass the parameters properly into functions, which would cause errors on the model - things like passing in “rate = dropout”, instead of just “dropout” into Dropout layer. It might not be because of this particular line, but this is an example of what I mean. You can play around with it, and read the instructions carefully again.

1 Like

Hi @Teresa_M_Behr,

Can you share your lab ID with me ? In the assignment, when you click the top right “Help” button, a panel will open and your lab ID will be shown at the bottom.

I shall take a look.

When you reply back, kindly tag me in the post so that I’m notified.

Thanks,
Mubsi

@Mubsi Thanks for taking a look! the lab id is slmqjigr

I will also try sylviasc’s solution today and tag this thread again if that fixes the issue.

@sylviasc Yep, seems this was the issue… there were two places in previous cells where I only passed (dropout, mode) into the dropout layer instead of (rate=dropout, mode=mode). Thanks for the tip!

@Mubsi seems to be solved for the moment.

Great to know it worked! :slight_smile: