Learner error, grader timed out

I am getting an error every time I try to get my week 3 programming assignment graded. I’ve taken care of all the constraints, and tried all other things suggested by the community. Kindly help me getting it graded!

ye i am getting the same errors, not sure why

Hi @nickmuchi, I just tried it and it seems to be working fine. Can you describe the error that you get (or better send a screenshot)?

The error still persists for me as well.

Hi all,
I have the same error but it works all fine when I run it in the Coursera Jupyter labs, is it the same for you all?

It worked after several attempts, weird.

1 Like

It worked? how? For me, its still not working. Did you manually uploaded the downloaded file, or submitted from the Jupyter notebook submit button?

I submitted from the notebook button, just kept on trying, didn’t do anything different


Nicholas Muchinguri, CFA

I am getting the same error. There could be a problem here. Let me check.

I’m not sure if the grader measures epoch and duration. I had the same problem with no luck with tuning and ended up pruning the training data set to shorten the training time. It converged in 8 epochs and < 30s total. Otherwise, it would still converge in 8 or so epochs but time >> 30s.

1 Like

Hi everyone,
sorry for the late reply. The problem should be solved now. Let me know if there are any other problems.

I have same problem too

Hi @Mobina_mzh,
some eventually passed trying many times. So, if the error is actually ‘grader timed out’, proceed with your course, and from time to time try submitting your assignment.
Hope it works.

Yes, slicing the training set to reduce its size worked perfectly fine for me. I think everyone who’s getting this error must try this.

I’ve used the following options

  1. change batch size
  2. reduce number of convolutional layers and max pooling layers
  3. reduce units in Dense()
  4. refresh the page and remove the old file

But none of them are working… and I’ve been trying a number of solutions suggested by others for four days. Is there anything else I can do?

Hi cheounsoo! Please also make sure that your training stops in less than 19 epochs and you save your work before you click the Submit button. You might be running into the same bug mentioned in this post . If it’s still not working, feel free to reply to this thread.

Thank you! I managed to submit after I checked your suggestion and changed the units in my Dense layer.

Awesome! Glad it worked!