Logs for Tensorflow Introduction assignment


I am getting the following logs on the submission of assignment- Tensorflow Introduction

[ValidateApp | INFO] Validating '/home/jovyan/work/submitted/courseraLearner/W3A1/Tensorflow_introduction.ipynb'
[ValidateApp | INFO] Executing notebook with kernel: python3
2022-08-28 09:23:05.031274: W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library 'libcudart.so.10.1'; dlerror: libcudart.so.10.1: cannot open shared object file: No such file or directory
2022-08-28 09:23:05.031315: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
2022-08-28 09:23:06.252082: W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library 'libcuda.so.1'; dlerror: libcuda.so.1: cannot open shared object file: No such file or directory
2022-08-28 09:23:06.252118: W tensorflow/stream_executor/cuda/cuda_driver.cc:312] failed call to cuInit: UNKNOWN ERROR (303)
2022-08-28 09:23:06.252139: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:156] kernel driver does not appear to be running on this host (ip-10-2-35-140.ec2.internal): /proc/driver/nvidia/version does not exist
2022-08-28 09:23:06.252395: I tensorflow/core/platform/cpu_feature_guard.cc:142] This TensorFlow binary is optimized with oneAPI Deep Neural Network Library (oneDNN)to use the following CPU instructions in performance-critical operations:  AVX2 AVX512F FMA
To enable them in other operations, rebuild TensorFlow with the appropriate compiler flags.
2022-08-28 09:23:06.260894: I tensorflow/core/platform/profile_utils/cpu_utils.cc:104] CPU Frequency: 2999995000 Hz
2022-08-28 09:23:06.262736: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x5563420cf540 initialized for platform Host (this does not guarantee that XLA will be used). Devices:
2022-08-28 09:23:06.262766: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Host, Default Version
Tests failed on 1 cell(s)! These tests could be hidden. Please check your submission.

But when I run individual cell of notebook, All the test are passed

Thanks in advance.

Hi @Akshat_Zala ,

Please contact Coursera learner help centre for assistance. There is a live chat line which is the quickest way to contact them.

Sorry, but for some reason most of those messages are “normal”. I’m not sure why they can’t suppress them, because they do sound pretty scary.

But here’s the one message that means your code failed the grader:

It is unfortunate that the grader cannot be more specific about which function fails. Are you sure you looked through all the output in the notebook and checked that everything was successful? Of course it’s hard for the tests in the notebook to catch all possible bugs. One type of error that can pass in the notebook and then fail the grader is “hard-coding” things to match the test cases in the notebook. If the above suggestions don’t help, then we’ll have to look at your code. But we should do that in a private conversation and not in this public thread.

Please consider the above and then let us know if that’s not enough and I will send you a DM about further steps.

Hi Paul,

After posting the issue, I tried again and resolved the error by removing reshape() from the compute_cost method and resubmitting the code to the grader.

Thanks for helping me.

Akshat Zala

It’s great to hear that you found the solution under your own power. Yes, you need transpose operations in compute_cost for the labels and logits, but “reshape” is not the same thing as transpose, if that’s what you were doing. Onward! :nerd_face:

Ok, Noted. Will take it into consideration.