ModuleNotFoundError: No module named 'cv2'

H​ello, I’m working on the first week optional lab. I created the environment with conda and installed all the requirements, as explained on the github repository. But, when I try to import cv2 or cvlib I have the following error: ModuleNotFoundError: No module named ‘cv2’

I​’m pretty sure that the requirements are satisfied, indeed if I run the following cell on Jupyter Lab: !pip install opencv-python I receive the following message: Requirement already satisfied: opencv-python in /home/pc/anaconda3/envs/mlep-w1-lab/lib/python3.7/site-packages (

As suggested in a previous post, I also tried to invoke jupyter lab using the command python -m jupyterlab but the error persists.

A​ny ideas? Best regards, Vincenzo.

Hi @jeromy.bananafish (Vincenzo)
please take a look at the following link.
This problem has been faced by many learners so far. The suggested solution should help you
Please let me know if it helped


Hi fabioantonini,
thank you for your quick reply. Unfortunately your suggestions does not work for me. Anyway, I completed the assignment using Docker.

Best regards.

1 Like