Notebook behaviour not matching the video

Hello. I am trying to follow the video with my own Jupyter Notebook. I realized that in some cases, I get different results than what is shown in the video.
I understand that the system is not deterministic even at temperature=0.
However, in this case:

prompt = f"“”
Determine five topics that are being discussed in the
following text, which is delimited by triple backticks.

Make each item one or two words long.

Format your response as a list of items separated by commas.

Text sample: ‘’‘{story}’‘’
response = get_completion(prompt)

Instead of getting the list separated by commas, I get a numbered list. I tried to replicate in the Notebook inside the Training Platform and I get the same results.

  1. Government survey
  2. Department satisfaction rating
  3. NASA
  4. Social Security Administration
  5. Job satisfaction improvement

I managed to fix it by altering the prompt, to say:
Format your answer as a simple list of items, separated by commas.

and then it worked.
survey, satisfaction rating, NASA, Social Security Administration, job satisfaction

Sort of the same happens later on,
Give your answer as list with 0 or 1 for each topic.\

List of topics: {", ".join(topic_list)}

I get:
[1, 0, 0, 1, 1]

instead of the list where I would read:
nasa: 1
and so on…

That I don’t know how to fix. Any comments??

I fixed IT but dont save the notebook. The key is tune the prompt

Welp, won’t the temperature be affecting it?

Yup. I just added this to the prompt and it matched what was shown in the lecture.

Format: <topic name>: <0 or 1>

First, the question is a little unclear. Only the output from the notebook in “lesson 5 - inferring” is not matched with the video. Maybe this is resulted from the updated version of OpenAI ChatGPT. For me, I appended the following to the prompt:

Make your response format: the topic, then :, last 0 or 1

With it, I get the same response with that in the video.

I have the same issue but after I adjust Format

“Format your answer as a simple list of items, separated by commas.”
“Format your answer separated by commas.”

It work on my!

Although it recognizes my API key, and I haven’t used the API key at all, it still is giving me a RateLimitError.

If you use API, it will give you the RateLimitError whether you have used it or not.

So what do i do to make the code execute?

As of now i have all the required libraries and everything installed. I have just started the course but i am not able to get any output because of the Rate Limiter problem.

Any suggestions?

Do not execute all cells at one time in your Jupyter notebook. Execute one cell at a time with “Shift+Enter”. If there is a loop in a cell, ensure the loop limit no more than 3.

You can add in continuation to the Give your answer as list with 0 or 1 for each topic — “against the topic name”.