Problems with Chatbot

While I am playing with the chatbox examples, I am not able to run properly the chatbox, at the beginning, I was facing issues with the configuration of libraries, and I solved them using these lines:

pip install --upgrade "bokeh>=2.4.0,<2.5.0"

and then,

pip install "panel<0.15" "jupyter-bokeh<3.1"

But then, when the chat is finally rendered, it gets stuck trying to process the message. Any ideas of what is going on?

I’m running the chatbot exercise successfully on MacOS Python 3.11.3
bokeh 2.4.3
panel 0.14.4

No jupyter-bokeh at all

ModuleNotFoundError: No module named ‘jupyter_bokeh’
[0] TextInput(placeholder=‘Enter text here…’)
[1] Row
[0] Button(button_type=‘primary’, margin=(10, 0, 0, 0), name=‘Chat!’)
[2] ParamFunction(function, _pane=Column, height=300, loading_indicator=True)

What OS and jupyter version?

Also running MacOS M1, also made a conda environment. Not using VSCode. Using Jupyter notebook

MacOS M1
I’m running in VSCode, and I made and conda environment to try this

Two other people, each of whom is also using VSCode, report bokeh-related trouble. One of them reports a workaround at that thread. Hope it helps

@Juan_Olano notice VSCode is present in this thread, too. My Jupyter notebook env doesn’t have jupyter-bokeh and runs the exercise fine :thinking:

Thank you a lot, I have tried on Jupyter, and it is running well… I will go to take a look at the thread. Thanks again for your time.

1 Like

Hy everybody
I’m trying to run the pip install panel command and I can’t get it to run on my computer

I can’t finish installing this package.

Can someone help me please, thanks

Try the following command:

pip install panel==1.1.1

Yhank very much . it is
I was able to install it, again thank you very much.I was able to install it, again thank you very much, however i got this message

"PanelDeprecationWarning: ‘style’ is deprecated and will be removed in version 1.3, use ‘styles’ instead.
pn.Row(‘Assistant:’, pn.pane.Markdown(response, width=600, style={‘background-color’: ‘#F6F6F6’})))

what is happening?

1 Like

I have been able to fix it. It works well.
however I have a question.
if i run my chatbot in jupyter notebook it works perfectly, but if i run it in linux terminal i get nothing.
What’s happening?