Question & Answer, can't "from langchain.indexes import VectorstoreIndexCreator"

When it runs “from langchain.indexes import VectorstoreIndexCreator”,
always got error "ImportError: cannot import name ‘URL’ from ‘sqlalchemy’ (/Users/myaccount/anaconda3/lib/python3.11/sitepackages/sqlalchemy/

I tried to uninstall and install “SQLAlchemy”, still didn’t work.

1 Like

Dear @Norah_Xu,

Can you please send me your notebook as personal message to me. I’ll check the issues and let you know the solution.

Hello, Girijesh,

Thanks for your message. Please find my notebook file attached.
Many thanks,

{mentor edit: notebook removed}

1 Like

@Norah_Xu, please send your notebook via a personal message - not by posting it on the forum.

Click on the mentor’s name, and then click on the “Message” button. You can upload your file there.


Please upgrade your sqlalchemy package
use following command

!pip install --upgrade sqlalchemy

then restart your kernel

This will work.
Please let me know if you face any problem.


Thanks so much for your help. It works now! :star_struck:
Thanks again,

1 Like

Thanks Tom,

It works not as I did " !pip install --upgrade sqlalchemy" as Girijesh suggested.

Thank you!

1 Like