Suggeestion: Cost function

Hello everyone,

In the first week, in the video with the label of “Satisficing and Optimizing Metric”, and at 1:07, a cost function is defined. Usually, we want to minimize the cost function; however, here, we need to maximize the following formula:

cost = accuracy - 0.5*running_time.

I suggest to use

cost = -(accuracy - 0.5*running_time) or change the name “cost”.

What do you think?


Hey @n.hashemia,

Or we can just think about it as a negative cost :wink:

Thank you for your answer.
You mean:
cost = -(accuracy - 0.5*running_time) or change the name to “negative_cost”?

I think that the course is structured in a way to deliver a general idea in simple words. You can do either way, your intuition is correct.

1 Like