Tensorflow on Mac M1 (apple silicon)

Hi Everyone!

I hope this is not out of topic, in which case, feel free to remove it.

I am trying to work on some projects on my own applying what they teach us in the DLS, but I can’t seem to get tensorflow working on my Mac M1 Pro. I’ve tried everything I could find on the internet (Miniforge or miniconda arm64, apple metal, dependencies, etc) and nothing works, I don’t know what I’m doing wrong. So, should anyone have a guide on how to set up tensorflow to work in an IDE such as Spyder or pycharm for apple silicon (not Jupyter), that’d be awesome!



Hi @Turo,

From my experience, I ended up whipping back out my MacBook 2017 (intel chip) to work with Tensorflow.

1 Like

It wasn’t easy, but I got it working last year. There were several discussions, including one from me, on the Apple Developer forum describing various attempts at that time. Have a look, meanwhile I’ll see if I can find my notes.

Here’s one on getting tensorflow-text installed:

Here’s the one on getting TF installed:

Looks like a couple of other people had success with the approach I posted. Good luck, and don’t forget it’s a moving target…what worked then might not produce identical results now.

1 Like

I was able to mostly use these instructions and set it up:

But I have tf v10.0 and the C1W3 assignment specifically requires <=2.2, so I’m not sure I’ll be able to use the M1 for this.

1 Like

I created dedicated virtual environments for the deeplearning classes since they require specific older versions of Python, TF, and Keras. The AI for Medicine classes use a lot of special libraries that also have to be levelled. So I had one current, one for AI for Medicine, one for the NLP specialization, etc.

Do you have tf 2.2 on an M1? It seemed to me that the tensorflow-macos required for M1 only goes as low as 2.5: tensorflow-macos · PyPI

I think mine was 2.5 when I got it working last year. Will boot and confirm tomorrow.