`TypeError` after restarting kernel

Hi all,

I’ve run into this error twice now. I resolved it the first time by changing environments and restarting. That worked for one session but after restarting my kernel I now get the following error when importing the PyPDFLoader in the Vectorstores and Embedding demonstration.

My gut feeling is that it has something to do with the imports and some type of conflict with libraries depending on what was installed first or something… I’m not really sure but I definitely don’t want to have to set up a new clean environment every time I run my code.

File ~/anaconda3/lib/python3.10/typing.py:1158, in _SpecialGenericAlias.__subclasscheck__(self, cls)
   1156     return issubclass(cls.__origin__, self.__origin__)
   1157 if not isinstance(cls, _GenericAlias):
-> 1158     return issubclass(cls, self.__origin__)
   1159 return super().__subclasscheck__(cls)

TypeError: issubclass() arg 1 must be a class```

Thank you!
- Steve

What’s been working for me, in the case anybody else is trying to run this in their own environment is to run pip freeze in the deeplearning.ai environment and then only install the versions of libraries in there.