Ungraded Lab Week1 Cannot do Object Detection with New images

Hi All,

I am having problems trying to do object detection with new images in the ungraded lab, if I select a file of my own the image is returned as it is, there is no message of detected object even if I put the confidence level to 0.01.
I am on windows running in conda.
Can you please help me ?
Things I tried is to delete the previous downloaded weights for yolov3tiny but did not work.
Thanks for the help

Hi @AndresMontero1994
welcome to this course.
I’m trying to address yuor issue, but no luck so far. In my case I cannot reproduce your problem,
DO you see any output on the server.ipynb side?
In my case I see

INFO: Started server process [25512]
INFO: Waiting for application startup.
INFO: Application startup complete.
INFO: Uvicorn running on (Press CTRL+C to quit)
INFO: - “GET /docs HTTP/1.1” 200 OK
INFO: - “GET /openapi.json HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK
INFO: - “POST /predict?model=yolov3-tiny HTTP/1.1” 200 OK

Have you already tried to run the client.ipynb?

Hello @fabioantonini thanks for the quick answer,
Yes I have the same image as output but without boxes (keep in mind that I set the confidence interval to 0.1), for example take a look at this:
I added a new image (a clock image) to the images and there is no box.

I also tried an image of a dog (my pet) and the same issue, no box in the mage, I dont even see the message: Detected object with the confidence interval.

Hi @AndresMontero1994
OK it’s clear. I am going to modify the confidence on my side. I will keep you informed

1 Like

Hi @AndresMontero1994
I have tested on my side and I had mixed results.
Firstly I have downloaded the picture of your dog. With the default confidence=0.5 no way to detect the dog.
Anyway decreasing the confidence to 0.2 it worked.

The result didn’t change if I use yolov3 or yolov3-tiny

I have also tried to detect the first image taken from your previous post. It worked a bit better than in your case. The new clock has been detected


Then I have tried to detect a different image of a dog downloaded from the web.
Also in this case the dog has been detected only when the confidence decreased to 0.2

Then I have downloaded a car image from the web. The car has been detected with high confidence=0.7.


Same result for both yolov3 and yolov3-tiny models.

Also with a new apple image the results were a bit mixed. In this case only decreasing the confidence to 0.1 a couple of apples have been detected.


So it sounds as if the pre-trained models have some kind of limitation. These couple of models probably have been trained with few images just for illustration purpose, they are not so robust for sure.

Anyway I cannot understand why the detection of your dog and of the new clock failed in your case.

Hello @fabioantonini
Thanks for the help.
Can you please let me know the environment and OS you are using?
and yes I find it strange that this do not work on my side.
I noticed that in the images you provided we don’t see the message :
Detect object: clock wicht confidence level of XX
the same when you recognize the dog from my picture.

Hi @fabioantonini
I just got it to work! :slight_smile: , I had to delete the files that were download under the .cvlib folder and using yolov3 is now recognizing both the clock and the dog.
Thanks a lot for the support.

Have a nice day

1 Like

with which confidence? just for a comparison with my results.

The dog was detected with confidence level of 0.74 and the clock with 0.82

it’s better than mine. I will try to remove the .cvlib folder.