Utils.interact_with_slider in C3_W2_L3_Hurricane_Harvey_Implement

After I downloading all the working space on ‘C3_W2_L3_Hurricane_Harvey_Implement’ , I have tried to run the file on my computer.

However, It is lingering in the cell in the ’ 5.1 Analyzing pairs of images with GradCAM’ session without showing any graphical results. I think it is stuck with ‘utils.interact_with_slider’. How could i solve this?

I have waited for more than 30 mins.
Eventhough I can get the result from the web site, I woluld ilke to test it on my computer.

I am using tensorflow 2.10.0 in the windows 11.

Hi @Scalet_Jiheon_Lee,

If you have downloaded all the files from the workspace, then I believe it is a matter of having different package versions than what have been used on Coursera.

You can google pip freeze to figure out how to get the same packages as the ones used on the platform.


I also thought that those problems come from the package version discrepancy.
So I have tried to export package versions from the web version jupyter
notebook to a yml file. But they do not use the seperate virtural env for each project.

Therefore, I could not copy the yml file for this project from the web.
Eventhough I download the package version info using following lines…

conda list -e > req.txt

their working environment was composed of various interconneted packages.
I think they perform the various projects using one single environment.

So It is complicated to reproduce the lesson on my own computer,
eventhough I have downloaded all the materials.

So if you offer a yml file directly related to each lesson next time,
that will be more helpful. I think reproductivity is
one of the key issue for researches.

Thank you for your kind reply.
I will try your suggestion using pip freeze.

Best regards.
Jiheon Lee