W1- Getting error while importing sagemaker

TypeError: Descriptors cannot not be created directly.
If this call came from a _pb2.py file, your generated code is out of date and must be regenerated with protoc >= 3.19.0.
If you cannot immediately regenerate your protos, some other possible workarounds are:

  1. Downgrade the protobuf package to 3.20.x or lower.
  2. Set PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION=python (but this will use pure-Python parsing and will be much slower).
1 Like

I have the same error for Week 2 right after importing sagemaker.
Please if someone in the Deeplearning.ai team can give some advice. Thank you!


I am getting same error for W3 assignment Train a model with Amazon SageMaker Autopilot

. Please help!!

Same here

I received the same error in the week 1 assignment. Anyone has found a solution?

I had success pip installing protobuf==3.15.8. It’s not consistent with the error message but would have been the latest protobuf when our sagemaker==2.35.0 was released.

1 Like

Installing 3.20.1 works or even anything lower than this. What worked for me is just installing this particular version of the library at the start of the notebook i.e. even before installing other libraries.

Resolved for me with the following change, as recommended by other:

1 Like

This seems to work for me, thanks!

Another solution. Run:

import os

before sagemaker install. Worked for me.

yes this worked for me too