W3_unittest module is inactive, how to fix it?

I tried many time for final assignment but failed to any point. There is always an error message for each exercise that says no module named w3_unittest.

Hi Chris @chris.favila is this something you would want to have a look at!

Hi Gent. Unfortunately, I don’t handle this specialization. Maybe the M4ML mentors have insight into this if it’s already a known issue. If not, they can escalate it on their repo. Thanks!

1 Like

@gent.spah @chris.favila who can help then? :smile:

I can help. Can you please that you are running the source code step by step on the notebook and it is not showing errors? I mean before grading.

yes, there is no error when I run step by step coding. It showed up only in grading page.

I just tried again. There is no grading at all. I did screen copy for exercise 1, so you can see it passed the w3_unittest but failed to get the grading.

Thanks. I will try to find internally if there is a way for me to access your lab. I will come back with an answer

@Jonson.Liu also try using partial grading #grade-up-to-here and refreshing your workspace

Hi, I tried this #grade-up-to-date after I executed exercise 1&2, and put it in beginning of exercise3, and submit. but the message is still there and there is no grading yet.

DM me your lab, I will have a look at it

what do you mean DM? sorry I am not familiar with this term.

Direct Message, Click on my profile and select ‘Message’

@Jonson.Liu My colleague @Isaak_Kamau is already helping you. So, I leave it to him.

Hello @yjcb22 I have gone through @Jonson.Liu’s lab and everything has worked fine from my side with a 100% score. Do you have an idea of what might be wrong?

@yjcb22 confirm if you’re importing w3_unittest in your notebook?

@Jonson.Liu Did you already tried restarting the kernel and cleaning the output, then running one by one and finally then submit?

I just restarted the kernel and cleaned the output and run one by one step. I still got 0 grade as you can see below screen.
the other thing I would like to report is in the previous test, I upload the file with different name w3_unittest1 and changed all the relevant coding to w3_unittest1, but finally the message still the same, no module named w3_unittest.

Can you please go to the files of the lab and enter to the home folder and then check if the file is there with the same name? By file I mean the w3_unittest.

PS: of course this is an example, not the same files or the same lab.

yes, I checked. It looks like the same.