Week 3 Unet Auto Grader Doesnt Work

I tend to submit graded exercises seperatly each time i finish one. In this week i did that for the first exercise and then the second but when i finished the last exercise and got the “All tests passed” message i submitted and autograder said: “Function ‘unet_model’ is incorrect. Check implementation.”
Am i making a mistake or the auto grader has some problems? Because i already got the positive feedback from the notebook. And by the way i already tried every solution i could see on discourse and in the discussion tab but none seem to work. And i tried submittting in total of 20 times so i dont think it was a one time thing. Thanks in advance for the answers.

Hey @heisenbug , can you DM me your notebook ? I’ll take a look. Thanks.

Hi @Mubsi

I’m running into the same error yesterday. The Notebook show “All tests passes” but when I clear restart & clear output, save and submit. The grader shows the same error as stated above by @heisenbug . Am I missing something here ?

Below is the full trace of grader output:

Code Cell UNQ_C1: Function 'conv_block' is correct.
Code Cell UNQ_C2: Function 'upsampling_block' is correct.
Code Cell UNQ_C3: Function 'unet_model' is incorrect. Check implementation. 
If you see many functions being marked as incorrect, try to trace back your steps & identify if there is an incorrect function that is being used in other steps.
This dependency may be the cause of the errors.

Thanks !


Hey @mohammedayub44 , @heisenbug , please make sure you are not passing any hardcoded values in that unit_model function,

Check that. and if the you still find it incorrect, then kindly DM me your notebook as well @mohammedayub44

Hey @mohammedayub44 , as advised, please make sure you are not passing any hardcoded values in the graded functions.

In your case, @mohammedayub44 , you are. In your unet_model function, you are passing a hardcoded value for the number of classes.

1 Like

That worked. Thanks @Mubsi

1 Like