What would be the cause of zero accuracies?

As you can see in the image, the accuracies are continuously displayed as zeros for all the epochs. What would be some general troubleshooting tips for this?

So far, I have augmented the images as done previously in the course, and used ‘sparse_categorical_crossentropy’.

I just realized that the way I create the labels array is incorrect in parse_data method! I will try again!

I have fixed the way my labels array is created. However, I still get an accuracy in the range of 0.00xx ~ 0.05. I also saw this post about having to manually add 1 to any labels below 8 to compensate for the missing label 9, but still no luck. I have spent hours on this and would appreciate any input on my problem! I will attach my notebook as well!

[code removed - moderator]

The way you’ve corrected labels is incorrect. Your label range is in [1, 24]. The model is built to predict 24 labels in range [0, 23]. I recommend not doing label correction and instead going with the number of classes in the writeup i.e. 26. Don’t worry about the 2 extra nodes in the last layer since the specification asks to account for 26 signs.
Don’t forget to change the number of units in the last Dense layer. Please try it and update the post.