AssertionError: Squeezed predicted y shape = (32, 64) whereas actual y shape = (32,)

pls anyone how to solve this? where and how to change the shape?
I tried many times.

Does this help?


do you know how to reset the whole thing so i can do it all over again?

Please follow these steps to refresh your workspace

hi balaji.ambresh,

I followed the instructions and got it. thks

@balaji.ambresh I have the same issue

@DhruvPatel Please read replies a bit closer:

NO i am not getting it.

Have you completed deep learning specialization?

Yeah i have completed and i also got it.

Thank You.

I am also getting this issue, the fixes suggested are not working, very frustrating

Got the same error. Created model as per instruction: Skipped lambda layer, added Conv1D, LSTM layers followed by few Dense layers.

Please pay attention to return_sequences argument in your NN.

Thanks. I was able to compile the model successfully.

Posting solution code in a public topic is discouraged and can get your account suspended. It’s okay to share stacktrace on a public post and send code to a mentor via direct message. Please clean up the post.