C1 W1 optional challenge: For Mac M2

Hi everyone

Did anyone face an issue with documentation on
machine-learning-engineering-for-production-public/course1/week1-ungraded-lab/mac_m1.md at main · https-deeplearning-ai/machine-learning-engineering-for-production-public · GitHub section

The following section did not work for me –

Install Tensorflow

Install TF dependencies:

conda install -c apple tensorflow-deps

– i downloaded the tar file from Tensorflow Deps :: Anaconda.org
and then did a install from my directory. The apple channel did not work for me

Install TF for mac:

python -m pip install tensorflow-macos

Install TF Metal plugin:

python -m pip install tensorflow-metal Install Tensorflow

Same for the above two packages, SYSTEM_VERSION_COMPAT=0 pip install tensorflow-macos tensorflow-metal this worked for me.

Anyone else with a M1 or M2 facing similar issue or any thouhts , highly apprecate it!

Thanks in advance!

Can I know if you got any error? Could you share why you are not able to use? probably with a screenshot when you tried to install tf dependencies

For tensorflow-deps:

The error message says channel is not available but its there.
Snapshot below:

The only way it worked was manually downloading the tar file and then installing it locally

But these two were fine after the flag name SYSTEM_VERSION_COMPAT=0

Ok based on what images you shared, seem like you trying run the ungraded cabin your local environment and the error is telling you some of the package are not available but your channels do show those packages are present.

Then the last image is tell the system version is not matching with the tf you are trying to download.

Here is what you need to do,

check the compatibility between your Mac version, python version and the tensorflow version, As do not have detail about what version you are using, I can only tell you way to find the solution.

Hope you understood the issue.

Also any of your personal system related screenshot, share via DM for your system security purposes.

Also sharing a link from the apple support answer to a customer having similar issue, probably this might solve your problem (but make sure first check your package versions and system version)

https://forums.developer.apple.com/forums/thread/683757

Regards
DP

SG! Thanks Deepti! The python version is correct at 3.8 and my mac os is Sonoma 14.4.1. Will ping you the details in dm

1 Like