C1_W3_Assignment Exercise 3 & 6 errors

or exercise 3, my output is the same as the expected output. However, the test cell shows an assertion error. The same error pops up in exercise 6 as the assertion error from exercise 3. The screenshot is attached below:

This means your code for initialize_parameters() does not pass the additional unit tests. This means there is an error in your code.

The test in the notebook (which gives the “Expected Output”) is extremely simple, because W and b are both scalars.

The unit tests use more complicated shapes for W and b.

Check your code for initialize_parameters(), and be sure your W and b have these shapes:

Thank you, I got the problem resolved.

How can you help out. This assertions error is not getting resolved

@Roshan_Rk, please post a screen capture image showing your assert or error message.

{moderator edit: code removed}

When i am running unit test this error pops up

Please look at the code and read the instructions:

Also, please do not post your code on the forum. That isn’t allowed by the course Honor Code.

I replaced them with the variable instead …it worked. Thank you