C2W2: All Tests Passed, But Still Getting Errors in The Last Cell


For C2W2, My code passes all tests (including for helper functions and graded cells), but when I try to run the last cell, I keep get the following assertion error:
AssertionError Traceback (most recent call last)
Input In [15], in <cell line: 6>()
4 assert relevant_indices[9] == 34
5 assert len(relevant_indices) == 10
----> 6 assert highest_covariances[8] - (-1.2418) < 1e-3
7 for index, covariance in zip(relevant_indices, highest_covariances):
8 print(f"{feature_names[index]} {covariance:f}")


My “highest_covariance” list:
[-2.95045456 -2.70398689 -2.55714255 2.04774456 2.00526176 1.99620265
1.85742121 1.58251848 -1.24037611 -1.20735615]

My [8] value is “-1.24037611”, but it seems the author of the notebook expects “-1.2418±0.001”

I can post the code for my graded function if it is okay.

Hi Sosi!
Hope you are doing well. Thanks for notifying this. I tried it too and it is strange to note that I am getting the same issue, will check it out why it is happening so, and will report to the team.
But please proceed to submit the assignment. You won’t face any issues and you can pass the assignment (I have checked it).

I run into the same issue too… the calculated value is highest_covariances calculated_value=0.0013654068032111777 , larger than 1e-03

I ended up commenting that line to see the results. it is interesting to see how some features are heavily correlated (high covariances). Perhaps the disentanglement work we have done before can come in handy here!

Thank you all for the replies.

Hi all,

I can confirm that I am running into the same issue.
When I comment out the assertion, I do see which features that are heavily correlated and which are not - very interesting!

Hi Anton,
I guess it’s just the nature of this assignment to end up like this. The maintain motivation is to get us to understand “what happens”. So please don’t worry about the results.
But regarding the issue, I will check out the possible reason and will report to the team if required ASAP.

If this could be updated that would be great; I was going crazy thinking that somehow something was wrong on my end. Definitely not conductive of learning for anyone trying to complete this in the future.

Hi all,

I have the same issue in the C2W2.

@Pavelk, thanks for the ping on this. I passed along a reminder to the developers since I suspect they accidentally overlooked @Nithin_Skantha_M 's original report.

This issue has now been fixed in the assignment.

1 Like