C2W3 Assignment Exercise 7 running at colab

Run ok upto Exercise 6. At exercise 7, getting this error. Same error on the same step in C2W3 Lab2 IterativeSchema notebook run at colab.

Versions being used at colab are:
TensorFlow version: 2.4.2
TFX version: 0.30.0
TensorFlow Data Validation version: 0.30.0
TensorFlow Transform version: 0.30.0

Need an alternative location to run the exercises for later use. Hence important for me to have it run at colab. Please help.

Hi Sanjoy! Can you try removing the instance_name argument inside the call to ImporterNode()? So it will just be source_uri and artifact_type remaining. That might have been removed in the version you are using. Hope it works!


Thank you Chris! It worked! Now I got the assignment running fully at colab.
Question is why did it work at colab without that parameter and worked in coursera notebook with that parameter. What environment difference causes this?
Secondly at colab folder train_uri is created as /content/pipeline/Transform/transformed_examples/7/Split-train where Split-train is created instead of train. So one has to make that small change in train_uri.
Thank you again.

I am also getting error at same step. But for me i am using ‘tfx.components.ImportSchemaGen’ instead of ‘ImportedNode’

Anybody can help me here or i need to create new query?