C2W4Lab1: "NotFoundError: /usr/..." occurs when try to run Transform component

I coded at Colab, below ImportError occur when I ran the Transform component:
NotFoundError: /usr/local/lib/python3.7/dist-packages/tensorflow_addons/custom_ops/text/_parse_time_op.so: undefined symbol: _ZN4absl14lts_2020_09_2312ToUnixMillisENS0_4TimeE

Had tried: !pip install -U tensorflow-addons
and the Error still occurs.

Besides, I can’t import this module: from tfx.utils.dsl_utils import external_input
As long as I try to import it, it said: ModuleNotFoundError: No module named ‘tfx.utils.dsl_utils’

Don’t know weather those two issues are related or not.
Need helps on this.
Thanks a lot~

Hi Damon! I haven’t tried with the later versions of TFX but for the version used in the Coursera Labs, the pip installs at the start of the notebook should be:

!pip install -v tfx==0.24.1
!pip install tensorflow_addons

After restarting the runtime, the rest of the components should run as is. Hope this helps!

Hi @chris.favila , thanks ~

Tried & RuntimeError occur:
RuntimeError: Failed to establish connection to Metadata storage with error: MLMD database version 6 is greater than library version 5.

It seems there’s a MLMD database version issue.

Oh that’s strange. It’s working fine on my end. Can you upload this Colab and retry from there?

C2_W4_Colab_Lab_1_WeatherData.ipynb (39.2 KB)

Hope it works!