C3 W1 Lab2 cannot run

Can some one (staff member) post a working installation of dependency for this lab to run?
The following installation turns out not working:
!pip install --use-deprecated=legacy-resolver tfx==1.3.0

!pip install apache-beam==2.32.0

These are downgraded to work with the packages used by TFX 1.3

Please do not delete because it will cause import errors in the next cell

!pip install tensorflow==2.6.0

!pip install --upgrade tensorflow-estimator==2.6.0

!pip install --upgrade keras==2.6.0.

Thanks a lot.

The staff are aware of the need to upgrade the labs. That said, please ignore the ERROR text in the output and restart the runtime after you install dependencies. I just tried it and can confirm that the imports in the next cell work.

Thanks. After trying it again, I confirmed that the original setting was working.
However, it worked almost in a magical way. I installed the dependency packages, and re-started the runtime, but it didn’t work. I almost gave up, and thinking tried it again. So I re-run the installing dependency again and it turned out that after the 2nd installation, everything worked.
Previously I tried many different ways, such as changing the version of tfx and/or beam, to no avail.
Thanks a lot.

You’re welcome. These are the steps to follow:

  1. Install libraries (once is sufficient)
  2. Restart runtime via Runtime > Restart runtime. (Don’t pick the option to Disconnect and delete runtime since it’ll clear the environment)
  3. Run the cell that’s after installing libraries which is usually the one containing imports.

If an error occurs in the lab, please bring it up on this forum for the mentors / staff to fix.