C3_W1_Lab_2_TFX_Tuner_and_Trainer can't install old TFX version

Colab expects to pip to install an “old” version of TFX:

!pip install --use-deprecated=legacy-resolver tfx==1.3.0

Looks like 1.3 is no longer installable via pip (from the default location).

Has anyone worked around this yet?

Thanks for reporting. The staff have been notified about this.

Hi Jeff! Welcome to the community! The lab is now updated. Thank you for reporting!

I m still getting installation error in this lab. PFA the screenshot.

Hi Chetna. Kindly revisit your classroom for the new link to that lab. It has been migrated to run on Coursera while our partners are working on compatibility issues with Colab’s Python3.10 runtime. Thank you.

I am also facing the same issue in Google Colab. I have tried installing tfx version 1.12.0 and 1.13.0, still same error occurs. There is no option to run this notebook inside coursera. Could you kindly tell, how to handle this issue?

Hi Sara and welcome to the community! Can you post a screenshot of your Coursera classroom where you got the link to this item? Also, when did you enrol in this course? We might need to escalate this to Coursera because it seems like your in an old session. Thanks!

Hi Chris,
Thank you for your response. I have enrolled for this specialization, a month ago. I have start this course today. I am hereby attaching the screenshot of my Coursera classroom for your reference.

Hello @Sara_vana
Can you try this solution
!pip install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.13.1-py3-none-any.whl
Let me know if it works

Hi Sara. Your screenshot is for Course 4 but the lab is for Course 3. The Coursera link is on that course. We’ll make adjustments to the Github repo to avoid confusion. If you still want to try it on Colab, you can try these steps:

  1. Type Ctrl/Cmd + Shift + P to bring up the command palette
  2. Select or type “Use fallback runtime version”

That will use an old Python runtime. But I highly encourage that you run it in Coursera instead in the Course 3 classroom. Hope this helps!

Hi Chris,
Isn’t course 3 - “Deploying Machine Learning Models in Production” and course 4 - “Machine Learning Modeling Pipelines in Production” ?
I have shared the screenshots from course 3 from coursera and corresponding lab from GitHub repo. I am confused, would be highly helpful if you could point what I am missing here.
Thank you for your support.

Hi Isaak, Thank you for the comment. I tried this solution, after changing to tensorflow-1.13.1, colab prompted to restart the runtime. After the restart, still I am getting the same error while installing tfx in colab

Sorry for that, try on Chris solution
You can please share your Colab link? I would like to try out some solution later

Hello. Course 3 is Modeling while Course 4 is Deploying. The lab you’re referring to is on this item.

Thanks a lot for the clarification Chris. I guess, I was wrongly referring to the course number in Coursera. However, I tried “Use fallback runtime version” in colab, it shows “the fallback runtime version is unavailable at this time”. Would love to debug and solve the same in local or colab environment.

No worries. Thanks for the suggestion. Here is the colab link: https://drive.google.com/file/d/1oHu0604Ty1ksr7NuCa-gplpUPFRxLcfp/view?usp=sharing

Unfortunately, we’re not maintaining the Colab version for now because we’re waiting for a fix from our partners. They’re working on TFX support for Python v3.10 so it can run on Colab again. The fallback runtime was a temporary workaround and it looks like Colab has dropped it now. I just remembered the fallback was only supposed to work till end of May. Colab makes that available temporarily when they update their Python versions. We’ll update the repo and course asap when the dependencies are fixed. Thanks!