C3W3-Assignment-Image Segmentation of Handwritten Digits-Submission Error

Hello guys!
I am currently doing the C3W3 assignment called the ‘Image Segmentation of Handwritten Digits’. as you can see from the screenshots i have trained the model and it passes the requirement. I got a score of 65%

But when i submit the model.h5 file i am getting the error ‘There was a problem grading your submission. Check stderr for more details.’

I have no idea what to do for this error. Any help is welcomed.


before starting the assignment did you rename your assignment and save a copy?

Also can you send me the notebook via personal DM. Don’t post code here, it is against community guidelines. Sometimes grader is looking for particular loss and optimizer and if you have used a different one, then also can create grader issue.


Check this thread where many people had the same issue but issue resolution were different. So check if you have all the tick marks required for grader pass


as per discussion, you can save a copy of your work and re do your assignment.

While copy and pasting some of the codes, you have edited the grader cells which can also cause grader failure due to metadata editing.

Kindly refrain from copy and pasting codes.

Every notebook gets updated with the metadata grader has assigned and when you copy and paste codes from outside, you will never pass the grades.

Also this kind of practice is not allowed. Remember the graders will know when you copy-paste codes.

In your encoder cell, Zero padding’s layer is not followed as per the instructions given.

In the decoder cell, the data_format is incorrect.

Also while I was checking your codes you choice of activation in the decoder grader cell is incorrect.

in the instructions it is clearly mentioned which activation need to be used and you while copying didn’t notice that

append a sigmoid activation

o = (tf.keras.layers.Activation(‘softmax’))(o)


your model compile is incorrect, especially optimizer. Can I know what do you mean by this nesterov=True),???

Also if you notice in the expected output the epoch used is 70 and you have used 200!!!

Try again, you can refer anywhere you want but do not copy-paste codes. Read every instructions carefully, half of the hints will be in instructions.


Thanks for the reply,

for the epoch i tried it with 70 but the accuracy is very low so i tried it to 170 and 200. I will check the other suggestions and come back soon.

the accuracy is low because of other reason from model compile. refer the weeks’ videos again and the ungraded lab.

whenever you get stuck with error, try searching that error in the community to find solution. if you don’t find solution, put the error log here in the community (not the codes), mentors will surely guide you.


I see, thank you so much!

Happy to help!!!

Keep Learning!!


The issues is resolved and i passed the assignment !
(I don’t know why but the epoch that was set to be 70 wasn’t enough for passing the assignment… so i got a good range of epoch between 170 and 200)

probably your model varied with the grader model had planned.

I had used epoch 70. Using anything higher to 100 was causing my model training to crash. So probably there will be always variation in every learner models. The importance is to follow basic key points while doing these assignments and I hope now you know one should avoid copy-pasting codes :slight_smile:

Glad to hear you passed your grader.
Close the thread by choosing appropriate comment to your resolution.
Keep Learning!!!

1 Like