C3W3 Creating clusters error out

HI Chris,

I have already the project by hit and trial all the commands I got from internet.

Here is the screenshot, today again the given commands do not run at all.
And also the commands that ran successfully for me.

This is only assignment in which there was so much struggle to find each command. I am surprised how it was running for you and the other mentor without any changes.


Still the issue remained as the console was not setting PROJECT_ID to the value, and was an empty string.
I managed to complete it by giving the value directly in all the commands.


Hi Suparna! Thanks for the update and glad you were able to complete the lab! Unfortunately, I am not able to replicate your issue. I tried the commands as is and got the expected results:

From your initial screenshots, it seems like there are some additional arguments when you pasted the commands and that might be the cause of the issue. For example, instead of gcloud config set compute/zone us-central1-f, the screenshot shows gcloud config set compute/zone us-central1-f project (notice the additional project). Maybe removing that and running the 1st block of commands one line at a time would have made it work. Nonetheless, it was great that you found a workaround to finish the lab. Thank you for being resourceful and apologies for not being able to reply quickly.

Next time, I think you’ll get a faster response if you post a new topic. This old thread is already considered solved so the mentors may not be monitoring it anymore. An open/new topic usually gets more attention.