C3W3 -Problems with Distributed Multi-worker TensorFlow Training on Kubernetes

Hello!, i’m having problems completing this lab, i got 70%, but i got an error in the Preparing TFJob.
I´ve tried all things that appear in other topics, but still doesn´t work.

these are the problems i got:

Please help!, i need to complete this Lab to finish the course.

Hi there. You should not paste python code on terminal and expect it to work. The snippet you have on the 1st image is something for you to notice inside main.py. Please read instructions carefully.

Don’t forget to remove code from your posts.

I don´t know where to find mnist folder and the files, i understand that i need to check in the files the information to complete the code. Can you help me with that?

Sure. This is the file under consideration. Please go through the qwiklabs instructions again to get a better handle on the lab. In my opinion, the lab is well written.

I’m also having an issue with the final part of this lab. I believe I entered all of my project_id information correctly and where asked, but when I try to submit the TFJob it keeps saying ‘retrying in 5s, 10s, 15s,’ and then throws an ‘file does not exist’ error. It may be because I don’t know how to update the --saved_model_path and --checkpoint_path, but I don’t see any bash script or info on how to do that.

Read this section in the lab page:

Next, update the --saved_model_path and --checkpoint_path arguments by replacing the bucket token with the name of your Cloud storage bucket. Recall that your bucket name is [YOUR_PROJECT_ID]-bucket.
The updated manifest should look similar to the one below: