C4W2 Assignment grading

I’ve tried a number of different models, some larger, some smaller.

My last model:
391/391 [==============================] - 4s 10ms/step - loss: 0.0028 - accuracy: 0.8033 - val_loss: 0.0027 - val_accuracy: 0.8211
79/79 [==============================] - 0s 4ms/step - loss: 0.0027 - accuracy: 0.8211
(147k parameters)

The loss is less than 0.01 and accuracy greater than 0.6, so this seems fine?

Displaying the results they look like what I would expect, but…

There was a problem grading your submission. Check stderr for more details.

I can’t check stderr, so I have no idea what went wrong, any hints? Is it testing something specific inside the network or is the model too large?

As long as you haven’t change any cells you are not supposed to alter, then its probably the model architecture and specifics of layers and settings in the layers themselves. It should be similar to models given in the Labs or close to them. Give it another try…

Same is happening to me. As I saw in previuos posts, apparently there is compatibility issue between the grader and the default TF version in Colab. Previously in February, it seems they fixed it with this code:

!pip install tensorflow==2.6.0
!pip install keras==2.6

But now Colab can not find a version that satisfies the requirement tensorflow==2.6.0, so they created a cell with this new code:

!pip install tensorflow==2.8.0 --quiet
!pip install keras==2.8.0 --quiet

To me the problem is there, as people have the same issue before. My accuracy and loss are both OK, I tried with different models, all of them accomplished what is asked for and I could not check.

I’ll be waiting for an answer, I need to pass this assignment to get the certificate. Thanks!

Hello there,

I ran the assingment and uploaded it myself and I passed 100%, as I said

If you still get stuck on it though I might have a look at your assignment code later on then I guess.

I see. I created now an exactly equal architecture as the convolutional autoencoder lab, and it worked. Thanks for the patience.

PD: You may have to import by yourself the MaxPooling2D’s layers, which are not suggested or imported in the code by default.

1 Like

I did not change any cells but the ones we’re supposed to edit and didn’t really change the architecture when I got it to be happy (I don’t recall what I changed, but I’m almost certain it wasn’t the model).

It would be really great if the error could be improved, there’s obviously something the grader is unhappy about, and telling me that it’s on stderr isn’t helpful (maybe that’s a Coursera limitation?)