C5W1A1 - can't submit?

I can’t submit the first assignment. If I click on submit next to the ‘trusted’ label an ‘error’ label shows up in the background. The popup for the submit shows no progress, I can only click the ok button but nothing is submitted.
I tried various time to restart the kernel, delete all files and get the newest version of the file (and then try to submit the newest version without changing anything) … all to no avail.
If I open the second assignment and just click on submit it works just fine (of course the grader says I failed because I didn’t do any coding). But the point is that I can submit the second assignment without issues.
I have also trouble saving the first assignment. I have to hit the save button like 20 times until I don’t get an error message and the file is saved.
As I have no trouble submitting the second assignment I can’t see what I can change on my side.
Any help appreciated !


Your description (can’t submit, can’t save) implies that your session is busy doing something in the background.

Did you at some point add code to any cells that outputs a lot of debugging data to the browser?

Also, did you try “Help → Reboot Server” ?

I tried to submit again but to no avail. When opening my workbook (without doing anything) it shows ‘error’ → see screenshot.

Submitting ‘hangs’ → see screenshot

I didn’t add any output code. When running manually, every cell is executed quickly and all checks seems to be ok.

So I am still totally stuck.

There is no ‘Help → Reboot Server’ in my workbook ?
I tried ‘Kernel → Restart’ and ‘Kernel → Restart and clear output’ but this changes nothing.
There was a description how to start over. I tried that also and started again with a fresh copy of all files and cut&pasted my changes into it but the result is just the same.

I am also getting some strange messages that my files have been changed on disk ? → see screenshot.

I completed all assignments in the first four classes without any of these issues but in class 5, week 1 assignment 1 I am totally stuck. Please advise.

I didn’t do the optional/ungraded part of the assignment.

You will get these “notebook changed” messages if you modify the name of the notebook, or if you save a copy with a new name.

Do not modify the notebook name - this is a sure way to confuse the grader.

Another tip about Course 5 is that you cannot submit your work for grading until you have completed the entire notebook. Attempting to submit a partially-completed notebook will make the grader crash.

Other thoughts:

  • Is your course subscription still valid?
  • Check the “Help” menu in the upper-right corner and see if there is a new version of the notebook available.

Isn’t it also the case the that hitting “Submit” in Course 5 does not do an “autosave” for you, so it won’t be grading what you’re actually seeing in your notebook unless you manually do a save. It also looks from some of the other errors you show that “Save” is not working for you. That may be the real underlying issue and is probably the first thing to debug. Try this sequence and see what happens:

  1. Kernel → Restart and Clear Output
  2. Save

It’s also possible that what you have here is an IT problem on either your computer or your local area network where some A/V software is blocking some operations that the notebook is trying to do. You might want to try using a different computer or try accessing the website from a different network (e.g. a public WiFi at a coffee shop or a library) instead of your work or school network. Note that this is the very first assignment in C5. Have you taken earlier courses in DLS and been able to submit with no problems? Or is this your very first attempt to use any of the course notebooks?

Yes, indeed.

One reason you might not be able to save your notebook would be if the kernel is still busying running your code.

so if this could help, i confirm that i had exactly the same problem (with the error on saving also). Just by changing the computer (was using more “closed/protected” computer), and now it is submitted without any issue using my personal computer.

Thank you for the support.

“Kernel->restart and clear output” and then “save” just creates the same error. it says “autosave failed” and “error” so this did not help.

Like I said before, I did not have any issues with courses 1 to 4.

When hitting the ‘save’ button I am getting the ‘error’ label - if I do it once. If I hit it like 20 or 30 times then it will finally say ‘saved’. I can’t see how this could be a problem with my pc blocking some actions - it would either work or not but not ‘sometimes’.

I don’t know how to switch computers. I do not have personal login information for coursera (like a username/password). I am using a company pc and when logging into coursera I just click on a ‘log in with company-name’ button. I can’t see how this should work with my private pc.

How do I check this ?

I only changed the name for making a backup copy to start over with a fresh copy of all files - this did not help either.

Finally, after hours and hours of trying I could submit my assignment.
I had to hit the save button like 50 times, then I am getting at some point the ‘file changed on disk’ dialog, then I clicked ‘overwrite’ and immediately ‘submit’. In other words: there is no real solution. None of your hints did work. Sorry to say that. But thanks for trying to support. I hope the next assignment will not be the same pain.

I suspect something in your notebook was keeping the kernel busy, so that it could not either save your work or run the submit task.


Thank you for offering to have a look at the notebook but, as I was finally able to submit it, I would rather proceed to the next assignment. If I have issues with the second assignment as well I will get back to you.