Cannot submit notebook C2W3 DLS

Cannot submit assignment
Permission denied : release/W3A1/Tensorflow_introduction.ipynb

Hello @nihil!

Several students facing this issue. We already informed the course staff to look into the issue as soon as possible. We are extremely sorry for the inconvenience caused to you because of this error. We understand how frustrating this is but we have no other option but to wait. Sadly, we don’t know the exact time when the problem will be resolved but hope they will resolve it soon.

Your patience will be highly appreciated. Once they resolve the issue, we will inform you.


Same for other notebook(s):

Permission denied: release/W1A2/Convolution_model_Application.ipynb

Hi @Oli ,

This problem happens across a number of specializations. The staff team is working on it and an update will be posed when the problem is resolved.

1 Like

Hi everyone! Sorry for the delay.

Kindly try this:

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate with the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

You “might see an error about checkpoints failing. I think that’s okay because that’s related to the permissions of the hidden .ipynb_checkpoints folder. That is not needed for grading as far as I know. The changes should persist in the actual notebook itself even if they see that error. I submitted the notebook and got the expected grade.”

@Oli @nihil


Hi Saif,

unfortunately I cannot even duplicate or create new files

Could you please help me out here?



We informed the Coursera staff about that and waiting to hear from them. We are extremely sorry for the inconvenience. Please wait for a while.
Meanwhile, you can try this temporary hack but it worked for some and didn’t work for others.

@dtetiana @Oli @nihil


this has worked for me. Thanks, Saif:)

Hi Siaf,
Thank you for the help, but I also cannot make a duplicate
I got Permission denied: release/W3A1/Tensorflow_introduction-Copy1.ipynb
Just to inform. Hope, it will be ok soon

Hi, folks!

If this temporary hack didn’t work for you, kindly refer to that post . You will need to submit your info as mentioned there.


1 Like

It’s resolved the problem for me, thanks!