Can't Create a Duplicate Notebook nor can save/submit


Since yesterday, I have been unable to save or submit my notebook for C2W3.
Furthermore, I tried the work around which consists of creating a duplicate notebook; however, I keep getting the following error: “Permission denied: release/W3A1/Tensorflow_introduction-Copy1.ipynb”.

This is interesting since this only occurs with this notebook and not any of the others I have worked with throughout the specialization.

Any input and possible solutions are greatly appreciated!

Jinal Shah

Hi @Jinal_Shah! Sorry for the delay.

Kindly try this:

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate with the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

You “might see an error about checkpoints failing. I think that’s okay because that’s related to the permissions of the hidden .ipynb_checkpoints folder. That is not needed for grading as far as I know. The changes should persist in the actual notebook itself even if they see that error. I submitted the notebook and got the expected grade.”


Duplicate does not work. I get an error Permission Denied.

I have the same “Permission Denied” issue since last night. Cannot save/submit/duplicate.

One student posted this. Kindly try this.


It did not work for me. Ignoring the error and reloading does not show the duplicate.

Same here. I cannot make any changes to the lab files.

We informed the course staff about Duplicate failed. We are extremely sorry for the inconvenience.


Still getting this, do I just wait for it to be resolved?

I lost all my changes to the last assignment (Tensorfow introduction), so for anyone else who’s trying to save / submit & failing, you’d better download the ipynb to keep it.

Hi folks,

Kindly try this temporary hack that worked for many with a few exceptions. If it is not working for you, kindly refer to that post . You will need to submit your info as mentioned there.


1 Like

This worked, thank you!

@Jia_Xu @pkumar13 @Jinal_Shah