Course 1 - Week 1: Connection Error

Here it is:

(I cut it off at the right, because otherwise the image text gets too small.)

This is exactly what I have in my case.
Now please open the link shown at the bottom of the picture in your browser.

When I run the docker image I get the following messages:

[I 19:45:24.388 NotebookApp] 302 GET /?token=b99228c9e0c896f2466868696761bbc4bc70d318e35c8520 ( 1.370000ms
[I 19:45:30.573 NotebookApp] Writing notebook-signing key to /home/jovyan/.local/share/jupyter/notebook_secret
[W 19:45:30.576 NotebookApp] Notebook work/server.ipynb is not trusted
[W 19:45:30.677 NotebookApp] 404 GET /nbextensions/widgets/notebook/js/extension.js?v=20210909194303 ( 15.620000ms referer=
[I 19:45:31.756 NotebookApp] Kernel started: 3823d733-3656-4ad5-b097-6d292fc2d9e9, name: python3
[I 19:47:32.165 NotebookApp] Saving file at /work/server.ipynb
[I 19:51:32.179 NotebookApp] Saving file at /work/server.ipynb

Yes, get the same thing:

Hi @Jacob
have you been able to manage the issue?
I cannot figure out what is wrong.
Can you verify the settings under "Resources/Proxies’’ of the your Docker Desktop? Mine is disabled.

@fabioantonini - thank you very much for following up!
I was - it was a third-party security software that was running on my device. They were able to resolve the issue for me.

1 Like

Great to hear that!
Can you share some additional details about the fix? It might be helpful to any other learner.
Happy learning and best regards

Sorry, I don’t know the details - they did it on their end.
It’s a company called Techloq.

No problem @Jacob
It’s important you can move ahead!
Keep in touch

Hi, I am facing the exact same issue. Only difference is I am using the Method 1: Python Virtual Environment with Conda. I did verify that the URLs are accessible from my browser and there are no proxy setup either. Could you please help trouble shooting this issue?

Downloading yolov3-tiny.cfg from
Could not establish connection. Download failed
Downloading yolov3_classes.txt from
Could not establish connection. Download failed

Please ignore. Manually downloaded the respective files and placed in the folder. This resolved the issues.

Hi, which folder should i put them ? thank you.

[quote=“Vighnesh_M_Rajan, post:29, topic:10884”]
[/quote] change the file name “yolov3.txt” to “yolov3_classes.txt”, then it will be ok

download all the required files from below commands in ubuntu

copy all these downloaded files in running container

docker cp yolov3_classes.txt container_id:/home/jovyan/.cvlib/object_detection/yolo/yolov3
docker cp yolov3-tiny.weights container_id:/home/jovyan/.cvlib/object_detection/yolo/yolov3
docker cp yolov3-tiny.cfg container_id:/home/jovyan/.cvlib/object_detection/yolo/yolov3

Hello, I have faced the same problem on my Ubuntu18.04 host machine. I have downloaded all the dependent packages in the directory same as the server.ipynb. But when I run the docker cp commands you mentioned, the terminal just report an error msg which says: Error: No such container:path: 3f2e553c3a27:/home/jovyan/.cvlib/object_detection/yolo where 3f2e553c3a27 is my container id. Is there any solutions for that? Thanks a lot

Sorry… I miss to respond your query.
Is it resolved now ?
If not then:
hint1: please cross check you are running cp command in right directory ??

I encountered the same error, and I resolved it by updating the model version. Specifically, I replaced “yolov3-tiny” with the more recent “yolov4_tiny”. Similarly, if you are using “yolov3”, you might consider upgrading to “yolov4”. I am running this code in a Conda environment on Windows. Although this is a response to an old post, I thought this someone might find it useful as a quick fix.

Downloading yolov3.cfg from
Could not establish connection. Download failed