Docker: error during connect - Course 1 - week 1

I got an error when I try to run the docker for second time. When I first installed Docker following the steps in the assignment I did not have any problems. However, I did start again today, and I could not connect to Dockers. The message says: "error during connect: This error may indicate that de docker daemon is not running. Post “http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/images/create?fromImage=deeplearningai%2Fmlepc1w1-ugl&tag=jupyternb” : open //./pipe/docker_engine: The system cannot find the file specified.
I am using Windows Terminal, and I did got the files needed according to the git clone instructions at the beginning of the instructions. I mean, I can see:

week1-ungraded-lab (this directory)
    ├── images (includes some images from ImageNet)
    ├── server.ipynb (Part 1 of the ungraded lab)
    ├── client.ipynb (Part 2 of the ungraded lab)
    └── requirements.txt (python dependencies)

I would appreciate your help.
Thanks in advance.

In addition, if I go to Windows Task Admin and I check the “Services” tab I can see that “com.docker.service” is in execution mode. So it is running.

It is solved. I had to switch to PoweShell elevated mode and then run the following command:
docker run -it --rm --user ContainerAdministrator
After that I did execute the pull and it worked.
Hope this helps if someone finds the same issue.