Course 4 Week 2 Assignment 1 Error in Assignment 1 ResidualNets

I have done everything correctly but it is still showig AssertionError: Wrong values when training=True.

Please share your full error.


This is the error


Also I am getting this error in # UNQ_C3 # GRADED FUNCTION: ResNet50

I have solved the error

I am glad you solved it on your own.

It is always joy when we are able to solve our own error while we are looking for solution for our error. You must be happy :slight_smile:

Great work!!!

Regards
DP

I have the same problem. Have found anything?

@Writobrata! Please share your wise words on how you solved that issue (without revealing the code). So, others can be benefitted from it…

Hello Sina,

It is better you create a new post by choosing the appropriate specialisation, course, weeks’ and assignment name, with the screenshot of your error encountered. So all mentors can help you promptly.

Regards
DP

Hey guys I’m having the same issue here!

AssertionError: Wrong values when training=True.

There is not much that I did in the assignment (I just wrote a few lines of code), so I’m not sure what can be the source of the problem

Hello campagna,

It is always better to create a new post with the issue/error encountered screenshot and select the appropriate Specialisation, Course, Weeks and assignment’s name. For getting better response/ help from mentors.

Also try searching similar issues in the search bar AssertionError: Wrong values when training=True. DLS C4 W(choose which week assignment you are doing) and you will find related post were such issues have been addressed.

If you didn’t find solution, always create a new post with a screenshot of your error and not code

Regards
DP

Thank you Deepti for the reply. I’ll create a new post about the issue because I couldn’t find any solution in other threads. I understand this is related to the recent fix about the “training” parameter.

My code is quite simple so I think there could be a problem in my understanding of the assignment. Is there any chance that the fix didn’t work?

Your information about issue encountered is not understandable due to no idea about which specialisation, course and weeks’ assignment you are doing. That’s why I told you to create new post according to the explanation given before your reply. Of course most of the issues are fixable, just need to see/search the right way or with the help of mentor’s guidance. For that we need to see screenshot of your error but please always create a new post

This thread is about the Residual Networks assignment in DLS C4 W2 (ConvNets). They did recently issue a new version of that assignment that eliminates the training variable. I recently upgraded to that new version of the assignment and it all works for me.

I am having the same problem. I double checked the code i could not find the error. @ccampagna1 Did you get it to work? What was the problem?

Sure. In the shortcut path we were required to use batch normalization. Instead I used an activation function. That’s why the output tensors were wrong.

There are lots of details to check here, like the one that Writobrata mentions. It’s basically an exercise in proofreading and comparing your code to the instructions. If going over everything one more time doesn’t yield any bug fixes, check your DMs for a message from me.