Course 5 Week 4 : Can't find exercise 4


i was going through the Transformers exc, but i got stuck at some point , so i went and reviewed codes here and at github, i figured out that there is a whole function (exercise 4) is missing, i don’t know if this is a bug, or i did mess with the notebook without noticing that.

the missing part is for the Encoder layer, i have the description and the test cell only, and don’t have the code cell

appreciate your help, or should i just go and insert this cell myself ?

Hi @msaid,

There’s a “how to refresh your workspace” reading item in the first week of the course, before the first assignment, follow those steps and you should get a fresh copy of the assignment notebook. It will have all the code cells in it, in case you accidentally deleted some code cells from your current copy.


I just checked the master notebook file that you get when you install or update the assignment.

Section 4.1 is not missing from the file.

Since you’ve reported missing cells in two different assignment notebooks, and no one else is reporting a similar problem, I think there is something wrong with how you are editing the notebook - somehow some cells are being deleted.

Hi @TMosh , i just rechecked the file and the cell i’m talking about wasn’t the only cell that wan hidden. after reviewing the notebook again i found the following

  • exc 4 (encoder layer) cell was combined with markdown cell and hidden in additional hints section
  • the “” import wasn’t there in the import packages cell and that lead me to get an error while executing Some test function like EncoderLayer_test(EncoderLayer)

i solved the first problem by getting the code into a separate cell, and the 2nd one by adding the import manually.

i’m sure that i didn’t remove, combine any code cells. any way thanks for your help

Hi @Mubsi ,
i tried all refreshing option. the network stayed the same, given that i have solved the problem. but is there any way to reset the noetbook ? i mean i need to get the original notebook without any modifications ?

Thanks for your help

I do not think there is any problem with the notebook files.

That most likely means that you did not follow the instructions correctly. Note that the “get latest copy” procedure only replaces missing files (this was clearly described in the instructions), so you have to rename your notebook to a different name in order to get the clean copy.

Hi @msaid,

Exactly like what Paul said. To be on the safe side, use option 2 for refreshing your workspace.