Course Vidoes do not work


I started the Sequence Models course, however, some vidoes won’t play, e.g.
Why sequence Modes, Backprop though tome, Different Type of RNNs.
When I open the vidoe I get a message ‘Oops, Something went wrong’. Reloading and trying later does also not work.
Other videos in this couese work fine.
Any idea?

Hi @Jordinho

I’d recommend trying to access the videos using a different browser/device/network, clearing your browser’s cache. (or double-checking if your DNS or VPN is working properly)

1 Like

Hi @Jordinho,

I experienced the same for the Sequence Models course, I’m guessing, the same time as you were, and faced the similar error. After a while, I was able to access the course normally. I’m guessing it was some sort of glitch on Coursera.

Try again now and let me know if you are still facing the issue.


I saw the same issue over the weekend.

cache clearing did not work, but using Edge instaed of Chrome worked. Thanks

Good to hear that! You’re welcome :raised_hands:

Unfortunately, it worked only for one video. Now I experience the same with the other videos that did not work with the new brower. However, when I completely close the browser and open a new inkonito window and login again. I can display one other video. So that seems the procedure now. Logout, close th brower, log in again and so on. Cumbersome.

Just tested the course, I’m using Chrome and Firefox, and the videos are all playing correctly.

Perhaps you have an issue with one of your browser extensions, a firewall issue, or your internet provider is unhappy.

@ TMosh: That I would suspect, if ALL videos wouldn’t work, but it affects only SOME.

The course itself seems to be working fine. Maybe you have some security or pop-up blocker issues in your browser.

I don’t have any other suggestions.

Might be. That would partlally explain, why using an incognito window seems to work. Still, it is strange that for all the previous courses in this specialization, I did not have this problem. Thanks anyway.

Different videos may load different resources, and one of them might be blocked or have compatibility issues with your environment. I’m able to view the videos without any issues. To troubleshoot, I would recommend investigating your firewall settings, browser settings and add-ons. You could also try installing a different browser to see if the problem persists. By isolating all possible causes, you can determine what might fix this issue.

1 Like