Error In Deployment

In Week 1 ungraded lab , while using Docker , when you open the local host and paste the token in the jupyter lab, it gives error “Invalid credentials”

hi @himanshu_birla , could you double check the token by pasting it into a text editor before paste it to Jupyter Lab? Just in case if there is a space at the end or equal character at the beginning.

Hi tranvinhcuong!

I have tried ample times . It is giving the same error!

@himanshu_birla , could you give more information about the machine you are using (what kind of OS, type of user, usage of sudo etc…), and some screenshot about the error? (I tested Docker on Linux without any error )

Hi @tranvinhcuong, I got the same error “Invalid credentials”.

I work on Mac M1, pasted the the following command under week1-ungraded-lab directory:

  • docker run -it --rm -p 8888:8888 -p 8000:8000 --mount type=bind,source="$(pwd)",target=/home/jovyan/work deeplearningai/mlepc1w1-ugl:jupyternb

The terminal then gave a WARNING as below:

Then I pasted the link and the token into chrome, it then gave the error: “Invalid credentials”

hi @Damon ,
Can you try again and adding --platform linux/amd64 as an additional parameter for docker run ? I do not have a Mac M1 here, so cannot test it before replying.


Hi @tranvinhcuong, I have just fixed the “Invalid credentials” problem, by clicking the “run” button at Docker:

Then I do the “docker run -it …” as before, and I no longer need to paste the token to login.

But, after successfully assessing, I shut down everything try again: without opening Docker, just do the “docker run -it …” as before, it still works.

So, I’m not sure clicking the “run” button is a cure, or pure luck.

On the other hand, I tried as you suggest, and it returned as below:

@tranvinhcuong, I encountered another issue after successfully login.

Every time I try to run the cell of “import cvlib as cv”, the kernel die.

Then I try to install the cvlib in notebook via “pip install cvlib”, and it’s saying “Requirement already satisfied”.

Then I restart the kernel and try to import cvlib again, the kernel still dies every time I try.

Can’t fix this “import cvlib as cv” issuse.

Thanks for trying, and it’s great that you found the solution!

I think put the parameter at the end make the docker recognized it as a path to image, but you can put it like after -it or somewhere before the image name. And I do not guarantee it fix the issue so actually does not need to try anymore :slight_smile:

@tranvinhcuong, Sure.

By the way, I tried to put the " --platform linux/amd64" after -it, and it does solve the “platform” WARNING.

Thanks a lot.

1 Like

sorry, do not have any clue about this error… hope that other mentors or learners may have a solution for this.