Four birthday problems lab - issues with loading the lab

I have started W1 of the Probability and Statistics module and am trying to launch the lab - however, all I get is a blank space as the lab tries to load unsuccessfully. I have tried loading the lab in three different browsers and have encountered the same issue again and again before finally loading in Chrome after a wait of a few minutes.

However, after the lab loads, I have issues running the program - for example it takes a few minutes to run the following step which is:

# Generate the simulated probability for every classroom
simulated_probs_1 = [simulate(problem_1, n_students=n) for n in utils.big_classroom_sizes]

# Create a scatterplot of simulated probabilities vs classroom size
utils.plot_simulated_probs(simulated_probs_1, utils.big_classroom_sizes)

Can someone help me with speed issue?

Hi, @yauhooi1

By your description of the problem, it looks like it was a problem with the virtual machines that Coursera uses to run the Notebooks. Since it’s been some time from your post, I would like to know if the problem is still occurring.


Hi @lucas.coutinho,

I have just tried to load up the same exercise and this time round it took less than a minute. Therefore it appears that this is no longer an issue. Thank you very much!