GANs Course 2, Week 1, C2W1_Assignment

I have passed the programming exercise, but still have doubts whether the model displays correct results.
At “Putting it all together!” the progress bar stops at 127/128, moreover, the value that is shown after the execution of the last cell block seems rather high to me: approx. 84.48, probably a value around 30 (or something above) is expected. Are the two points related to each other? If necessary, I can also send you the notebook file …
Thank you for your support!

Hey @Volker_Drewes,
I don’t have much idea about the loop, cause in my case, it ran completely, perhaps it could be a server issue. But as for the FID score, it is 84.48 for me as well, so, I don’t think that you have to worry about that, it’s just the model chosen for the FID notebook is not state-of-the-art, so, as long as you understand the concept of FID, you should be good to go.

Hi @Elemento,
Thank you for your feedback on my question. I just wanted to make sure I didn’t miss anything. Wish you a nice day!

1 Like

Hi ! Can you download the “fid_images_tensor.npz” ? I made the code True, but them don’t work。
if in_coursera:
import numpy as np
data = torch.Tensor(np.load(‘fid_images_tensor.npz’, allow_pickle=True)[‘arr_0’])
dataset =, data)
dataset = CelebA(".", download=True, transform=transform)

Would you please share a copy of the fid_images_tensor.npz dataset? Thank you so much!

Did you manage to find the solution to the problem, Volker? I am also having the same issue but I am stuck at 126/128 instead. I’ve restarted the kernel a few times and the issue still persists.

Hello Timothy,
after successfully passing the exercise, and not receiving any answer except from Elemento, I have continued with (and meanwhile successfully finished) the GAN course. I just saw that there is also a reply from ColorfulWhiteZ, but I have not tried it. It’s a bit of a sad, but I have the impression that the support for this course is not so active …

So the answer to your question is: no - I have not found the solution for my problem, yet.

Have fun and success for the other exercises

Hey @ColorfulWhiteZ, welcome to the community. Can you please explain to me how exactly I can help you? Like do you want to run this notebook in your local system or are you facing issues while running this notebook in Coursera?


Hey @Timothy_S, welcome to the community. Since many of us are facing this same issue, therefore, I am assuming that there is an issue with this Coursera Lab. Let me report this to the team, and we will get back to you shortly.


The files for the assignments are all there alongside the notebooks. Here’s a thread about how to download them.

I also have this problem. It shows 126/128 or sometimes 127/128 and the progress bar is red. And the last cell in the notebook seems to hang forever. I neither get a result displayed nor an error message. I tried restarting the Kernel and re-running all the cells but with the same results.

I also tried submitting the assignment but it never seemed to manage to do it and now the button to submit is gone :frowning:

Ok, had to rename the notebook, refresh it and reenter all the code. Then the submission worked. When running the notebook I still get anything between 124/128 and 127/128 and a red progress bar but the the grader says everything is fine.

This sounds like a resource limitation problem on the AWS VMs that they use to run the notebooks. When you run the training for a lot of iterations, the memory footprint can get very large which slows things down and can interfere with submitting to the grader. One of the palliatives mentioned on the FAQ Thread for the “no submit button” case is to do “Kernel → Restart and Clear Output” to discard all the generated results and memory footprint. Of course you also lose the results of the training when you do that. Sigh … Unless you have your own captive hardware for running training, this is a problem with pretty much any online environment. If you are doing this kind of thing seriously, you need to add logic to checkpoint (save) the trained weights periodically and then structure the training logic so that you can restart and continue from a previously trained set of weights. That is beyond the scope of the course materials, but it’s easy to “google up” some instructions to get started down that path.

1 Like

Hi everyone,

I’m not sure if this is the right place to post, but I thought I’d try.

I am facing a technical difficulty where I have passed the assignment but the course progress does not seem to recognize it. Submitting an issue below the assignment did not seem to trigger a response (so far).

Is there anyone here that could help me either due to a trick that could trigger the progress to register, or by direct intervention? It’s been like this for more than a week and the deadline is approaching in 3 days. I have completed all other courses of the specialization and would very much enjoy having my certificate ready to go.

The screenshot below shows the current state of things. You can see my submissions and the missing green checkmark on the left. Any help is greatly appreciated!

This is a Coursera problem. Supposedly they are working on a solution, but it’s been going on for quite a while now. Here’s another thread with instructions about what to do.

1 Like

Thank you for the pointer!


I have the same issue: The fakes and reals features colleciton loop is stuck at 99% and 127/128

and the frechet_distance does not finish calculating. Submitting does not seem to work either.

Please help, kind regards,


I got a grading and a score. However the jointplots for the multivariant distributions do not work the way they are implemented in the notebook:

sns.jointplot(samples[:, 0], samples[:, 1], kind=“kde”) results in

TypeError Traceback (most recent call last)
Input In [22], in <cell line: 8>()
6 covariant_dist = MultivariateNormal(mean, covariance)
7 samples = covariant_dist.sample((10000,))
----> 8 res = sns.jointplot(samples[:, 0], samples[:, 1], kind=“kde”)

TypeError: jointplot() takes from 0 to 1 positional arguments but 2 positional arguments (and 1 keyword-only argument) were given

after fixing this (passing a tuple of the samples) the grading did not work.

Thank you, @Tobias_Schadauer!!

This used to work, so there must have been an update to seaborn. I’ll let the developers know so they can update the assignment to work with the current version of seaborn.

In the meantime, anyone else who runs into this issue, you can make the change @Tobias_Schadauer suggests like this to see the plot:

res = sns.jointplot([ samples[:, 0], samples[:, 1] ], kind=“kde”)

That will let you see the plot, but you’ll need to remember to take the brackets you added back out before you submit your assignment until this gets fixed.

The assignment has been updated now to fix this issue. Thanks again, @Tobias_Schadauer and @Shantanu1 for pointing this issue out