Getting error while downloading weights file in C2W3

Unfortunately I don’t have access to that environment now, but it seems like wget is not installed in the environment.

Have you tried to install it as workaround?

# Workaround to install wget
!apt install wget

# Download the inception v3 weights
!wget --no-check-certificate \ \
    -O /tmp/inception_v3_weights_tf_dim_ordering_tf_kernels_notop.h5

In the meantime I’ve opened an issue to fix it permanently.


Hi @german.mesa & @ABHISHEK_KUMAR_UPADH,

When I ran that colab, it got downloaded for me.

@ABHISHEK_KUMAR_UPADH, are you trying to run this on your local machine ?

!wget is a command line command and will not work directly in jupyter notebook. (It works in Colab though). You need to first install wget (pip install wget) and then import it like a normal library (import wget).

Unfortunately, I was not able to install wget due to auth issue, but I found a workaround. Here is the code that I use and it worked just fine. You can try this :slight_smile:

from tensorflow.keras.applications.inception_v3 import InceptionV3

pretrained_model = InceptionV3(input_shape=(150,150,3),
for layer in pretrained_model.layers:
layer.trainable = False