Grader Failure: "Programming Assignment: Emojify (Emoji_v3a)"

I did not see a problem during the programming and all tests have passed.
But, the submission scores 0/100 with the grader output;
Cell #8. Can’t compile the student’s code. Error: KeyError(289846,).

I tried “Restart & Clear Output” >> “Save and Check Point”, which did not work.

I think this could have happened since I tried adding some cells to see the data shapes.
Is it going to solve the problem if, somehow, I can start with the original template of the Jupyter notebook and paste the solutions that I have into this? That empty sheet for the solutions to be implemented, of course, I don’t have.

Problem resolved by restarting with a fresh, untouched notebook, following how to renew the notebook described in How to Get a Clean Copy of an Assignment Notebook .

Thanks for your report.

I met the same issue (all tests passed but got grade 0) on all my 4 trials since yesterday. I then did the above " restarting with a fresh, untouched notebook" from above link. But the grading still failed… Can someone help please? Thanks.

The most common cause for this issue is if you modify some parts of the notebook that the grader relies on. For example, modifying the definition of a graded function, or adding extra blank lines near the function definition, those will make the grader not able to compile your code.

Thanks for the info! So I updated the notebook again to get back to the very original clean assignment and redid the assignment manually line by line. but it still got 0/100… The grading error was “Cell #14. Can’t compile the student’s code. Error: KeyError(‘never’,)”. but cell #14 is actually the unit test which I did not do any editing… any other suggestions? It took me a lot of time already. Thanks.

Maybe there is a problem with the code you are entering, since the problem keeps repeating every time you input your code.