Grader Issue, Trigger Word Detection


I have completed the notebook and passed all the tasks, however I am getting the following error message from the grader: Cell #24. Can’t compile the student’s code. Error: FileNotFoundError(2, ‘No such file or directory’)

The output of the grader is 0/100. Can someone please help?
Thank you in advance,

1 Like

One of the files that the grader requires is missing from your notebook folder.

Thank you for the reply! How can i fix it?

You’re probably going to have to save your notebook as a local file, then delete all the files from your notebook folder, and re-install the assignment using the “Help” button.

Then you’ll have to re-enter your code from your local copy into the new notebook file.

Hi! Thank you again for the prompt reply :slight_smile:

I tried following your instructions, however it seems like the issue still persists. I already reported it as an issue with the grader for Coursera. Can you please inform if there is anything else I can do?

I don’t know of any way to fix a missing file other than by deleting everything from your notebook folder and re-installing the assignment.

I just tested the grader using my solution, and it worked fine.

Are you sure you followed the “get a clean copy” procedure documented on the FAQ Thread? Since it sounds like the problem is a missing file, you might start by trying the “Help → Lab Help → Get Latest Version” without moving or deleting anything to see if that helps. That procedure only replaces missing files.

I just tested it again and the system is not allowing me to delete three folders: models, raw_data and XY_train. I have emptied them, and I still get the error message that the directory must be empty before deleting. I am not sure what to do next.

I also tried this approach, and it is still giving the same error for me. I am happy to share the notebook containing my solutions if that is easier to grade :slight_smile:

Did you try “Get Latest Version”?

Yes, I went to Help → Lab Help → Get latest version. The issue still persists for me.

Hi, see file handling code line , I resolved it and this error went for me

Thanks for informing. Can you please elaborate further on how you solved the issue. I am not sure I follow what you mean?

The problem still persists for me and I cannot seem to get things working. I have already spent too much time on this. Can you please check the notebook and grant me the points? If not, can you please suggest what else I can do to fix the issue (would contacting Coursera help)?

Thanks in advance,

No one can grade your notebook by inspecting it. It must run through the grader.

I do not understand. Can you provide more details about this?

Thanks again for the reply, but I do not know what else I can do to solve it. Can you maybe send me all the files (minus the main notebook) so I can re-upload them? I can then add my own notebook containing the solutions

You should be able to get the files by restoring the notebook using the Help button.

As an experiment, I will try deleting all my files and see if restoring the notebook works correctly.
I’ll report back later.