Cell #24. Can't compile the student's code. Error: FileNotFoundError(2, 'No such file or directory')

I have this isue on week 3 of course 5 on trigger word detection. can anyone help me please? everything is all passed but i get this log

1 Like

Try restarting the kernel, then run all the cells again.
If you get any error messages, please post a screen capture image.

I have same problem and i don’t know how to finished it

Exactly same problem On C5 W3 Assignment2, Cell 2.

Already restart the Kernel, and run all the cells.

Can anyone help please?

Delete a cell that I modified, and then it got passed.

Likely caused by the modification made to the test/utility code.

Restore it to the origin maybe work.

Mine was on cell #24. Which cell did you delete?

Hey, were you able to resolve the issue with cell 24? I am still facing the same issue, i tried restarting the kernel, but the problem still persists.

I am having the same issue with cell 24. Why are the error just so vague and don’t give user any idea how to fix it. I have ran every cell and it runs fine and test-cases passes.

I have also tried with resetting the environment and it still gives the same error

I was able to fix the issue. Not sure what was causing it.
So I had to
Reset the environment to beginning: python - Coursera jupyterNotebook: revert to the beginning - Stack Overflow

and then had to do the assignment again.

I have the same problem. Already restarted and tried everything. How can I resolve it?

[quote=“JOHN_MATHEW, post:11, topic:60787, full:true”]
I have the same problem. Already restarted and tried everything. How can I resolve it?
[/quote]I have the same problem. Already restarted and tried everything. How can I resolve it?

We don’t know what causes this issue. So here are some questions:
-Which week and assignment are you working on?
-Did you modify any of the cells in the notebook other than the ones where you have to add code?
-Did you add any cells?
-Did you do anything in the notebook to add tests using any of your own files?
-Please check on the “Help” button and see if you have the current version of the notebook.
-Did you ever update the notebook after you started working on the assignment?
-Did you download the notebook to work on it locally, and then upload the notebook to submit it for grading?

Hello, I have exactly the same problem. Please see my answer to your questios:
-Week 3, assignement “Trigger Word Detection”
-No, I did not modify any cell
-No, I did not add any cell
-No, I did not add any tests from my side
-I checked, I have the latest version of the notebook
-Yes, I restarted kernel multiple times
-I downloaded notebook, tried to submit after uploading it, but didn’t do anything locally (all the development was done on the Coursera server).
The screenshot is below.
This assignement blocks me from completing DL Specialization. Please help me with this.

Please send me two pieces of information:

  1. Download your notebook and send it to me as an attachment in a private message.

  2. In your Notebook, open the “File” menu, and post a screen capture image that shows all of the files in your workspace.

Solved (at least one instance):

Be sure you have not modified the line of code that exports the “train.wav” file.

I have tried restarting the kernel, I made sure that I have not changed any cell other than those require coding. The system is still giving error: Cell #24. Can’t compile the student’s code. Error: FileNotFoundError(2, ‘No such file or directory’)

Kindly, help me out. I have tried all the solution given in this thread.

Have you got the solution?

Lileth had commented out a line of code that exports the train.wav file. That’s the file the grader could not find.