Grader platform error

Hi, grades takes ages after submitting week 4 exercise. Grading fails with error message " Platform Error: We’re experiencing some technical difficulties". I am retrying for several days but no improvement.

Hi @slesinger,

I just tried submitting and the grader graded relatively quickly for me. Can you try again to see if it’s fixed for you now?

If it’s still broken for you, you can DM me a copy of your .ipynb file for the assignment and I can compare it with mine to see if I notice any difference that looks suspicious. I’m not sure what that would be, but I’m happy to take a look.

If we can’t find anything that way, then it may be an issue between your environment and Coursera, in which case, you can try contacting the Coursera Help Center

@slesinger, thanks for DM’ing me your ipynb. Here’s what I found:

First, your code looks perfectly fine (as you probably already know). It looks like the problem stems from the changes you made to the values for grad_steps and skip in the “Generation” cell. Perfectly fine for experimenting, but it seems to be throwing off the grader.

The 100 you have for grad_steps will definitely make things slower than the original 10. The grader has fewer resources (specifically it uses CPU instead of GPU), so things that work fine when you’re running in the development environment can slow way down in the grader. I would have expected you’d see a more “normal” error in this case, like maybe a “Grader timed out”, but you seemed to have happened on an especially problematic combination that caused a more mysterious error message.

In any case, if you change grad_steps back to 10 and skip back to 2, you should be good-to-go for the grader.

Hi @Wendy , thanks a lot. The grader is happy again.

1 Like

I have the same problem. I tried many time to submit week 4 assignment but with no success.
For the last try, the error message was: “Sorry your submission was incorrect. Please try again. Expecting value: line 1 column 1 (char 0).”

It sounds like your assignment file may have been corrupted somehow. To make sure you have a clean copy of the assignment, you can follow these instructions from the MLS course on how to refresh your assignment
The instructions apply to this course, too.