How Can rerun programming assignment on my laptop

After finishing any Course How Can rerun programming assignments on my own laptop? Because when I downloaded it as a Jupyter Notebook and run there is data set missing error.

Hello @Muhammad_Sohaib1! Welcome to your community.

There are two ways to do this:

The first method I tried is: Download all the files, install Anaconda, open Jupyter Notebook, and keep all the files in one place, including the file in which you will write the code. You will also need to do pip install tensorflow etc.

The second method which I didn’t try is: Download all the files and upload it to Google Colab. Someone told me that you won’t need to install anything using Colab, but I didn’t try it.

Maybe there are some other ways too, which I don’t know.


The reason for the “dataset missing” error is that (as Saif says) you need a lot more files than just the notebook. From one of the running notebooks, click “File → Open” and you’ll get a file navigation view of all the supporting files that accompany the notebook. There is a topic on the DLS FAQ Thread about how to download all the files using a pretty easy method. There are no official instructions for how to install all the software you need if you want to run locally, but here’s a thread that will get you started that applies to DLS anyway. As you’ll see from reading that thread, it’s not a simple matter.

Maybe Colab is an easier path. I’m in the same position as Saif on that: I haven’t actually tried it with the course assignments. I have used it a bit though and one thing to point out is that you need to upload the course files to your Google Drive and then Colab references them from there. You may have to modify some code in the notebook to get the pathnames to work out correctly given the differences between Colab + Google Drive versus the way things work in the course Docker images.

Hey @paulinpaloalto, I was able to download all the assignment files and open that location in Jupyter Notebook.

However, it looks like it still can not access the required files.

any idea why this happens?

matplotlib is not a local file that is part of the assignment: it is a python package that needs to be installed in your environment. You had to install the Jupyter environment on your computer in order to even start the notebook, right? That’s only the beginning: you also need python, matplotlib, scipy, sklearn and eventually TensorFlow and so forth.

I’ve never actually tried running the notebooks locally, so I’m not the right person to help with this. My suggestion would be to try googling “how to install matplotlib locally” and see what you find.

There are also some threads on the forums that have instructions for this general process. Here’s one for example.

1 Like

Hi @Borrx

You need to download matplotlib on to your python terminal. Kindly follow the below link

Also one think you need to be sure of version mismatch as ipyml version of your jupyter should match with the version of matplotlib. This is jupyter related issue

If you are using JupyterLab 1 or 2, you will need to install the right jupyter-matplotlib version, according to the ipympl and jupyterlab versions you installed. For example, if you installed ipympl 0.5. 1 , you need to install jupyter-matplotlib 0.7. 0 , and this version is only compatible with JupyterLab 1

Hope it helps!!!


1 Like

Got it! I thought it was an access issue to one of the files provided with the downloaded assignment files.
Thanks for the clarifications.

1 Like