Issue with Zombie Homework setup

I am having an issue when I’m trying to run this set up script on colab for the zombies assignment: !python -m pip install models/research.

I get the following error:
Processing ./models/research
Preparing metadata ( … done
Collecting tf-models-official==2.8.0 (from object-detection==0.1)
Using cached tf_models_official-2.8.0-py2.py3-none-any.whl (2.2 MB)
Collecting tensorflow_io==0.24.0 (from object-detection==0.1)
Using cached tensorflow_io-0.24.0-cp310-cp310-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (23.4 MB)
Requirement already satisfied: numpy==1.21.5 in /usr/local/lib/python3.10/dist-packages (from object-detection==0.1) (1.21.5)
Collecting PyYAML==5.3 (from object-detection==0.1)
Using cached PyYAML-5.3.tar.gz (268 kB)
error: subprocess-exited-with-error

× python egg_info did not run successfully.
│ exit code: 1
╰─> See above for output.

note: This error originates from a subprocess, and is likely not a problem with pip.
Preparing metadata ( … error
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Any help would be appreciated here. thanks!


Hi Mubsi tagging you if this is also related to Coursera lab issue which we are currently facing.

Can you respond to the learner as I was unsure if the issue is related to Coursera lab but his error log does tell it might be.


Hi @srerrie,

I believe models/research might be a folder/file you need to download from Coursera, not as a pip package. I’m not sure, as I’m not aware of the contents of this specialisation.

Open your assignment, go to File-->Open..., this should open your workspace and you should be able to see the notebook and all the related files/folder. Click on the top right menu (I have forgotten what exactly it is), in order to download all of them.


Hi Srerrie,

I hope you are using an updated notebook. If you are after running the installation cell, you will notice a message written in the notebook

You can safely ignore errors about incompatibilities with the PyYAML version after running the cell below.

the only thing you need to follow is this in Import section


Let’s now import the packages you will use in this assignment.

Note: In Google Colab, you need to restart the runtime to reload the modules you installed in the previous section. Else, you will get an error. You can do so by selecting Runtime > Restart Runtime in the Menu bar. Please do not run the cell below without restarting.

So follow the same and continue with the assignment

Let us know if you are getting stuck in further down the assignment because of the same issue.


Ok so thanks for this reply. so now I’m trying to do the imports for the labels_map_util. would I just do something like from object_detection.utils import labels_map_util? When I do that, I get the error: ModuleNotFoundError: No module named 'object detection'. Even when I try to do from models.research.obejct_detection.utils import label_map_util I get the same ModuleNotFoundError. Any help with this would be appreciated. I feel like I’m missing something simple here.

Hi Serrie,

did you restart your runtime before importing files?

Yes. I did the set up of cloning the repo, creating the script and then doing !python -m pip install models/research. I get the YaML error, but I know to ignore that. I then went to restart the runtime like it says and then I execute the cell with the imports. Once I get to trying to import the modules from object_detection, I end up getting this error :frowning:


Can you please share the screenshot of the error you are getting?

Hi @chris.favila

The post creator/learner is facing the issue metadata-generation-failed as well as subprocess-exited-with-error, so when I had seen your comment on one of the similar thread to ignore as per the instructions given in the assignment as you had mentioned in the updated notebook all the necessary files would be there.

But turns out in the first grader cell where we import label map, we get an error.

I tried myself and I get the same error as srerrie, can you please look into this on how to correct this issue.

Thank you in advance

Hi Srerrie and Deepti. Thank you for reporting! This is now fixed. Kindly reopen the lab from the classroom to see the changes. Thanks again!

1 Like


As Chris has informed about issue has been fixed.

Can you try again and open the lab.

I just now run the notebook myself, looks like issue has been resolved. I was able to run the cells successfully, so you should too not have any issue.

Please let us know once your issue is resolved.

Thank you @chris.favila for addressing it promptly.


1 Like

I see the changes to the notebook and am able to proceed from that section. Thanks so much for the quick responses.

1 Like